SDK Updater: don't auto-expand archives when selecting a package

SDK BUG 2177033

Change-Id: I2c7af74e0dbbb3fc452e15e135b656a89bde4d31
diff --git a/tools/sdkmanager/libs/sdkuilib/src/com/android/sdkuilib/internal/repository/RemotePackagesPage.java b/tools/sdkmanager/libs/sdkuilib/src/com/android/sdkuilib/internal/repository/RemotePackagesPage.java
index 1898f66..a2432f9 100755
--- a/tools/sdkmanager/libs/sdkuilib/src/com/android/sdkuilib/internal/repository/RemotePackagesPage.java
+++ b/tools/sdkmanager/libs/sdkuilib/src/com/android/sdkuilib/internal/repository/RemotePackagesPage.java
@@ -272,7 +272,6 @@
     }

 

     private void selectCompatibleArchives(Object pkg, ITreeContentProvider provider) {

-        mTreeViewerSources.setExpandedState(pkg, true);

         for (Object archive : provider.getChildren(pkg)) {

             if (archive instanceof Archive) {

                 mTreeViewerSources.setChecked(archive, ((Archive) archive).isCompatible());