adb.py: require adb version >= 35 to use shell protocol.

Change-Id: I2513db8a88e1a1bd96ce642251882de97ca37df6
1 file changed