Set correct targetSdkVersion for DevelopmentSettings

This app shouldn't be used on API 14 or earlier, which is when
the real development settings panel was introduced.

Change-Id: I1436ff938aa66942c592d615b7bd5910e8cbfd88
diff --git a/apps/DevelopmentSettings/AndroidManifest.xml b/apps/DevelopmentSettings/AndroidManifest.xml
index c7b7e02..3dd0a0b 100644
--- a/apps/DevelopmentSettings/AndroidManifest.xml
+++ b/apps/DevelopmentSettings/AndroidManifest.xml
@@ -18,6 +18,8 @@
         package="com.android.development_settings"
         android:versionCode="1" android:versionName="1.0">
 
+    <uses-sdk android:minSdkVersion="14" />
+
     <application android:hasCode="false" android:label="@string/app_label"
             android:icon="@mipmap/ic_launcher_devsettings">
         <activity android:name="android.app.AliasActivity"