Bumping minimum version of samples.

All of these samples would not build because their minimum SDK levels
were too low. This CL changes these levels to the actual minimum
required to build.

Change-Id: I7a7f18d71f94b8982246b91bf6b48b073ec1db2f
(cherry picked from commit b149a3703dd6637ec5ee4ff096e1aef0f133736b)
13 files changed