Update wearable samples to use new base-build template

Also sets wearable/has_handheld_app=true as necessary, to preserve existing
Application folders.

This corresponds with build changes in commit:
73bf080d2015c589a1f144ee697a51a6dcf751d4

Bug: 18353265
Change-Id: I6a45b1ec11bea4bbf3a178312f4e57e0b10f4167
diff --git a/wearable/wear/AgendaData/template-params.xml b/wearable/wear/AgendaData/template-params.xml
index 83126ca..1414944 100644
--- a/wearable/wear/AgendaData/template-params.xml
+++ b/wearable/wear/AgendaData/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.agendadata</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/DataLayer/template-params.xml b/wearable/wear/DataLayer/template-params.xml
index 6c68e1d..8f89d67 100644
--- a/wearable/wear/DataLayer/template-params.xml
+++ b/wearable/wear/DataLayer/template-params.xml
@@ -18,8 +18,13 @@
     <name>DataLayer</name>
     <group>Wearable</group>
     <package>com.example.android.wearable.datalayer</package>
-    <!-- change minSdk if needed-->
+
     <minSdk>18</minSdk>
+
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
+
     <strings>
         <intro>
             <![CDATA[
diff --git a/wearable/wear/DelayedConfirmation/template-params.xml b/wearable/wear/DelayedConfirmation/template-params.xml
index 302c610..0b2f014 100644
--- a/wearable/wear/DelayedConfirmation/template-params.xml
+++ b/wearable/wear/DelayedConfirmation/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.delayedconfirmation</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/ElizaChat/template-params.xml b/wearable/wear/ElizaChat/template-params.xml
index 29ff39d..5f08502 100644
--- a/wearable/wear/ElizaChat/template-params.xml
+++ b/wearable/wear/ElizaChat/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.elizachat</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/EmbeddedApp/template-params.xml b/wearable/wear/EmbeddedApp/template-params.xml
index 6127940..9eb6378 100644
--- a/wearable/wear/EmbeddedApp/template-params.xml
+++ b/wearable/wear/EmbeddedApp/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.embeddedapp</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/FindMyPhone/template-params.xml b/wearable/wear/FindMyPhone/template-params.xml
index 640467a..f8cc0cf 100644
--- a/wearable/wear/FindMyPhone/template-params.xml
+++ b/wearable/wear/FindMyPhone/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.findphone</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/Flashlight/template-params.xml b/wearable/wear/Flashlight/template-params.xml
index d70083a..3e7145e 100644
--- a/wearable/wear/Flashlight/template-params.xml
+++ b/wearable/wear/Flashlight/template-params.xml
@@ -22,12 +22,8 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.flashlight</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
-
     <strings>
         <intro>
             <![CDATA[
diff --git a/wearable/wear/Geofencing/template-params.xml b/wearable/wear/Geofencing/template-params.xml
index 5530b02..6e66ecc 100644
--- a/wearable/wear/Geofencing/template-params.xml
+++ b/wearable/wear/Geofencing/template-params.xml
@@ -22,13 +22,12 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.geofencing</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
-
     <dependency>com.google.android.gms:play-services-location:6.5.+</dependency>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/GridViewPager/template-params.xml b/wearable/wear/GridViewPager/template-params.xml
index 0ac1ad3..c3d374d 100644
--- a/wearable/wear/GridViewPager/template-params.xml
+++ b/wearable/wear/GridViewPager/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.gridviewpager</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/JumpingJack/template-params.xml b/wearable/wear/JumpingJack/template-params.xml
index 7085d5c..8548c6b 100644
--- a/wearable/wear/JumpingJack/template-params.xml
+++ b/wearable/wear/JumpingJack/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.jumpingjack</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/Notifications/template-params.xml b/wearable/wear/Notifications/template-params.xml
index 939c45e..853c48a 100644
--- a/wearable/wear/Notifications/template-params.xml
+++ b/wearable/wear/Notifications/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.support.wearable.notifications</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/Quiz/template-params.xml b/wearable/wear/Quiz/template-params.xml
index 383a313..1952f2c 100644
--- a/wearable/wear/Quiz/template-params.xml
+++ b/wearable/wear/Quiz/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.quiz</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/RecipeAssistant/template-params.xml b/wearable/wear/RecipeAssistant/template-params.xml
index 5fe7af7..1d65259 100644
--- a/wearable/wear/RecipeAssistant/template-params.xml
+++ b/wearable/wear/RecipeAssistant/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.recipeassistant</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/SkeletonWearableApp/template-params.xml b/wearable/wear/SkeletonWearableApp/template-params.xml
index ea98d4a..a5c2056 100644
--- a/wearable/wear/SkeletonWearableApp/template-params.xml
+++ b/wearable/wear/SkeletonWearableApp/template-params.xml
@@ -18,8 +18,13 @@
     <name>SkeletonWearableApp</name>
     <group>Wearable</group>
     <package>com.example.android.google.wearable.app</package>
-    <!-- change minSdk if needed-->
+
     <minSdk>18</minSdk>
+
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
+
     <strings>
         <intro>
             <![CDATA[
diff --git a/wearable/wear/SpeedTracker/template-params.xml b/wearable/wear/SpeedTracker/template-params.xml
index b780173..6287a2a 100644
--- a/wearable/wear/SpeedTracker/template-params.xml
+++ b/wearable/wear/SpeedTracker/template-params.xml
@@ -22,11 +22,12 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.speedtracker</package>
 
-`
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
+
     <dependency>com.google.android.gms:play-services-location:6.5.+</dependency>
     <dependency_wearable>com.google.android.gms:play-services-location:6.5.+</dependency_wearable>
 
diff --git a/wearable/wear/SynchronizedNotifications/template-params.xml b/wearable/wear/SynchronizedNotifications/template-params.xml
index 972ab82..ab76712 100644
--- a/wearable/wear/SynchronizedNotifications/template-params.xml
+++ b/wearable/wear/SynchronizedNotifications/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.synchronizednotifications</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/Timer/template-params.xml b/wearable/wear/Timer/template-params.xml
index 43284b4..8414f70 100644
--- a/wearable/wear/Timer/template-params.xml
+++ b/wearable/wear/Timer/template-params.xml
@@ -22,11 +22,11 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.timer</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/WatchFace/template-params.xml b/wearable/wear/WatchFace/template-params.xml
index 0e6a7b3..af43f7f 100644
--- a/wearable/wear/WatchFace/template-params.xml
+++ b/wearable/wear/WatchFace/template-params.xml
@@ -22,13 +22,13 @@
     <group>Wearable</group>
     <package>com.example.android.wearable.watchface</package>
 
-
-
-    <!-- change minSdk if needed-->
     <minSdk>18</minSdk>
 
     <dependency>com.google.android.support:wearable:1.1.+</dependency>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
 
     <strings>
         <intro>
diff --git a/wearable/wear/WatchViewStub/template-params.xml b/wearable/wear/WatchViewStub/template-params.xml
index 0688686..1637cbb 100644
--- a/wearable/wear/WatchViewStub/template-params.xml
+++ b/wearable/wear/WatchViewStub/template-params.xml
@@ -18,8 +18,13 @@
     <name>WatchViewStub</name>
     <group>Wearable</group>
     <package>com.example.android.google.wearable.watchviewstub</package>
-    <!-- change minSdk if needed-->
+
     <minSdk>18</minSdk>
+
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
+
     <strings>
         <intro>
             <![CDATA[
diff --git a/wearable/wear/XYZTouristAttractions/template-params.xml b/wearable/wear/XYZTouristAttractions/template-params.xml
index 9fd87a4..81d3596 100644
--- a/wearable/wear/XYZTouristAttractions/template-params.xml
+++ b/wearable/wear/XYZTouristAttractions/template-params.xml
@@ -20,6 +20,10 @@
     <package>com.example.android.xyztouristattractions</package>
     <minSdk>18</minSdk>
 
+    <wearable>
+        <has_handheld_app>true</has_handheld_app>
+    </wearable>
+
     <dependency>com.android.support:appcompat-v7:21.0.3</dependency>
     <dependency>com.google.android.gms:play-services-wearable:6.5.+</dependency>
     <dependency>com.google.android.gms:play-services-location:6.5.+</dependency>