Merge "Use Java 1.7 for the default source and target compatibility" into lmp-docs