Make sure the EGLConfig is ES2-compatible

Bug: 6294310
Change-Id: Ib6913a4a27d5678de9f86de059f4ed948117bfa6
diff --git a/tests/tests/effect/src/android/effect/cts/GLEnv.java b/tests/tests/effect/src/android/effect/cts/GLEnv.java
index f9f55e7..6c559ad 100644
--- a/tests/tests/effect/src/android/effect/cts/GLEnv.java
+++ b/tests/tests/effect/src/android/effect/cts/GLEnv.java
@@ -31,6 +31,7 @@
     private EGLConfig  mEGLConfig;
 
     private static final int EGL_CONTEXT_CLIENT_VERSION = 0x3098;
+    private static final int EGL_OPENGL_ES2_BIT = 0x0004;
 
     public GLEnv() {
         EGL10 egl = (EGL10)EGLContext.getEGL();
@@ -45,6 +46,7 @@
             EGL10.EGL_RED_SIZE, 8,
             EGL10.EGL_GREEN_SIZE, 8,
             EGL10.EGL_BLUE_SIZE, 8,
+            EGL10.EGL_RENDERABLE_TYPE, EGL_OPENGL_ES2_BIT,
             EGL10.EGL_NONE
         };
         EGLConfig[] configs = new EGLConfig[1];