Deprecate both USE_GOMA and FORCE_USE_GOMA flags

Test:
m USE_GOMA=true GOMA_DIR=$(goma_ctl goma_dir) toybox
m FORCE_USE_GOMA=true GOMA_DIR=$(goma_ctl goma_dir) toybox
both result in error message being printed.

Bug: b/171325288
Change-Id: I94ccaf217dba71aca990d88d205bad669a49a2f5
Merged-In: I94ccaf217dba71aca990d88d205bad669a49a2f5
diff --git a/ui/build/config.go b/ui/build/config.go
index ef46bec..28ce57d 100644
--- a/ui/build/config.go
+++ b/ui/build/config.go
@@ -154,15 +154,9 @@
 		"EMPTY_NINJA_FILE",
 	)
 
-	if ret.UseGoma() {
-		ctx.Println("Goma for Android is being deprecated and replaced with RBE. See go/rbe_for_android for instructions on how to use RBE.")
-		ctx.Println()
-		ctx.Println("See go/goma_android_exceptions for exceptions.")
-		ctx.Fatalln("USE_GOMA flag is no longer supported.")
-	}
-
-	if ret.ForceUseGoma() {
-		ret.environ.Set("USE_GOMA", "true")
+	if ret.UseGoma() || ret.ForceUseGoma() {
+		ctx.Println("Goma for Android has been deprecated and replaced with RBE. See go/rbe_for_android for instructions on how to use RBE.")
+		ctx.Fatalln("USE_GOMA / FORCE_USE_GOMA flag is no longer supported.")
 	}
 
 	// Tell python not to spam the source tree with .pyc files.