Remove support for Darwin 10.6 SDK

Our minimum version is 10.8

Change-Id: I2f1984c2227861a3c784f2a5070853c2d1b250d6
3 files changed