Update mac_sdk_versions_supported.

Now we requires Mac OS X SDK version at least 10.8.
Also removed the unnecessary sort call in getting
Lexical sort doesn't make sense when 10.10 is added to that list.
Actually the next makefile line makes sure we always get the first
match in $(mac_sdk_versions_supported):
mac_sdk_version := $(firstword $(filter $(mac_sdk_versions_installed),

Bug: 22825165
Change-Id: I4bfafabb11f94b66704d4799fe61fe3f16429538
1 file changed