Update comments around PLATFORM_SECURITY_LEVEL

Bug: 29881091
Change-Id: Ib30aac55540513e43af147914f4470a78f368ef6
diff --git a/core/version_defaults.mk b/core/version_defaults.mk
index 558a035..068ed0e 100644
--- a/core/version_defaults.mk
+++ b/core/version_defaults.mk
@@ -100,9 +100,11 @@
 
 ifeq "" "$(PLATFORM_SECURITY_PATCH)"
   # Used to indicate the security patch that has been applied to the device.
-  # Can be an arbitrary string, but must be a single word.
-  #
-  # If there is no $PLATFORM_SECURITY_PATCH set, keep it empty.
+  #  It must signify that the build includes all security patches issued up through the designated Android Public Security Bulletin.
+  #  It must be of the form "YYYY-MM-DD" on production devices.
+  #  It must match one of the Android Security Patch Level strings of the Public Security Bulletins.
+  # 
+  #  If there is no $PLATFORM_SECURITY_PATCH set, keep it empty.
   PLATFORM_SECURITY_PATCH := 2016-10-05
 endif