Indicate that all emulator images support USB

The Android framework assumes that if an app uses UsbManager then there
must be USB support on the device. In order to deal with this the
emulator has to indicate USB support. Previously this was true for
Google SDK phone images because USB support is part of the common API
packages that gets installed. For AOSP and some other build targets USB
support was not included. This change indicates support for USB for all
emulator system images.

BUG: 28088069

Change-Id: I880210e89e6ad3412bdc069d6c20ed54a52cff83
diff --git a/target/product/emulator.mk b/target/product/emulator.mk
index d02c547..b08a28a 100644
--- a/target/product/emulator.mk
+++ b/target/product/emulator.mk
@@ -60,7 +60,8 @@
     device/generic/goldfish/ueventd.goldfish.rc:root/ueventd.goldfish.rc \
     device/generic/goldfish/init.ranchu.rc:root/init.ranchu.rc \
     device/generic/goldfish/fstab.ranchu:root/fstab.ranchu \
-    device/generic/goldfish/ueventd.ranchu.rc:root/ueventd.ranchu.rc
+    device/generic/goldfish/ueventd.ranchu.rc:root/ueventd.ranchu.rc \
+    frameworks/native/data/etc/android.hardware.usb.accessory.xml:system/etc/permissions/android.hardware.usb.accessory.xml
 
 PRODUCT_PACKAGE_OVERLAYS := device/generic/goldfish/overlay