Remove grouper bootloader version checks for AOSP

Change-Id: I5b2b925c97e1a861b3553a83ee95118494306a4a
diff --git a/board-info.txt b/board-info.txt
index 803df3c..cbd12f5 100644
--- a/board-info.txt
+++ b/board-info.txt
@@ -1,2 +1 @@
 require board=grouper
-require version-bootloader=3.37